I updated my ESXi 5.1 server to the latest ESXi 5.5 release. The process with smooth as it has always been in the past. After updating the tools for my guests I thought it was only practical to update the hardware level of my machines… I thought wrong.

The moment I upgraded the ability to edit a guest vm’s configuration using the vSphere client. When you make an attempt a message box opens with the following: “You cannot use  the vSphere Client to edit the settings of virtual machines of version 10 or higher…” And in forms you that you need to use the VMware vSphere Web Client

link” http://www.ivobeerens.nl/2013/10/01/watch-out-with-hardware-version-10-in-vmware-esxi-5-5/

I was able to correct this after the fact by creating a new configuration and attaching the the disk of the machine I recently applied the update to. Now I am back in business.