At the office we recently built two white box, built it yourself servers (lego’s). I called them Lego’s due to the fact they are build your own types and not OEM. For each of these powerhouse systems we got 3ware 9650SE RAID controllers (3ware 9650SE-4LPML PCI Express Lanes: 4 SATA II Controller Card RAID Levels 0, 1, 5, 10, Single Disk, JBOD, KIT).

After getting ESXi 5.x installed to a USB Stick to boot from I encountered an issue where the 3ware controller was not recognized by the system. Well this could only be one thing. Drivers.

This is where installing of the controller driver fun begins.

I first navigated to the LSI website and their support page to download the drivers for these controllers. Where I was able to find drivers for VMware ESXi 5.0 update 1 driver for 9650SE/9690SA

After downloading the zip archive of the driver, I extracted and used WinSCP to upload the drivers to the /tmp directory of my ESXi 5.x hosts.

I then logged into the ESXi 5.x using SSH with Putty.

After changing my directory to /tmp I ran the following command:

esxcli software vib install -v /tmp/scsi-3w-9xxx-

Soon after I got the following messages:

Installation Result
Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
Reboot Required: true
VIBs Installed: LSI_bootbank_scsi-3w-9xxx_2.27.08.036-1OEM.500.0.0.472560
VIBs Removed:
VIBs Skipped:

After the install I followed the instruction to reboot and after the systems were up and running again I was able to see the controller and create my new data-stores.